NetBeans Architecture Answers for HTML UI API module


Interfaces table

Group of java interfaces
Interface NameIn/OutStabilitySpecified in What Document?
HTMLUIExportedOfficial

NetBeans Platform specific bindings over standard
HTML for Java API.

net.java.htmlImportedPrivate

The module is needed for compilation. The module is used during runtime.

net.java.html.bootImportedPrivate

The module is needed for compilation. The module is used during runtime.

net.java.html.geoImportedPrivate

The module is needed for compilation. The module is used during runtime.

net.java.html.boot.fxImportedPrivate

The module is needed for compilation. The module is used during runtime.

net.java.html.jsonImportedPrivate

The module is needed for compilation. The module is used during runtime.

org.netbeans.html.ko4jImportedPrivate

The module is used during runtime.

org.netbeans.html.xhr4jImportedPrivate

The module is used during runtime.

org.netbeans.libs.javafxImportedPrivate

The module is needed for compilation. The module is used during runtime. Specification version 2.4 is required.

org.netbeans.libs.asmImportedPrivate
org.openide.awtImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 7.62 is required.

DialogsAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 7.30 is required.

FilesystemsAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 9.0 is required.

UtilitiesAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 9.3 is required.

WeakListener.setAccessibleImportedUnder Development

The module is needed for compilation. The module is used during runtime. Specification version 9.3 is required.

LookupAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 8.25 is required.

WindowSystemAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 6.71 is required.


General Information


Project and platform dependencies


Deployment


Compatibility with environment


Access to resources


Lookup of components


Execution Environment


Format of files and protocols


Performance and Scalability


Built on October 20 2017.  |  Portions Copyright 1997-2017 Oracle. All rights reserved.