Introduction

This document lists changes made to the Java Project API.


Index of APIs

Incompatible changes by date

Fuller descriptions of all changes can be found below (follow links).

Not all deprecations are listed here, assuming that the deprecated APIs continue to essentially work. For a full deprecation list, please consult the Javadoc.

All changes by date

Changes by version

These API specification versions may be used to indicate that a module requires a certain API feature in order to function. For example, if you see here a feature you need which is labelled 1.20, your manifest should contain in its main attributes the line:

OpenIDE-Module-Module-Dependencies: org.netbeans.modules.java.project/1 > 1.20

Changes by affected class

org.netbeans.spi.java.project.support.ui.BrokenReferencesSupport

org.netbeans.spi.java.project.support.ui.templates.JavaFileWizardIteratorFactory

org.netbeans.api.java.project.runner.JavaRunner


Details of all changes by API and date


Java Project UI SPI

Extended the BrokenReferencesSupport.createPlatformVersionProblemProvider by the mininal source level supported by the project

Mar 20 '17; API spec. version: 1.1.74; affected top-level classes: BrokenReferencesSupport; made by: tzezula
Extended the BrokenReferencesSupport.createPlatformVersionProblemProvider by the mininal source level supported by the project

Added a constant for execute module path into JavaRunner

Oct 4 '16; API spec. version: 1.1.71; affected top-level classes: JavaRunner; made by: tzezula
Added a constant PROP_EXECUTE_MODULEPATH for execute module path into JavaRunner.

Allows to extend the New Java File Wizard by project specific panels

Oct 4 '16; API spec. version: 1.1.71; affected top-level classes: JavaFileWizardIteratorFactory; made by: tzezula
Allows to extend the New Java File Wizard by project specific panels.

Desktop dependent Java Project Support UI extracted

Jun 2 '14; API spec. version: 1.62; made by: tstupka

The following packages were moved from org.netbeans.modules.java.project into the org.netbeans.modules.java.project.ui module:


Compatibility:

Runtime compatibility remains, compile time compatibility is mostly preserved too. It is however recommended to upgrade dependencies of client modules. Try running ant fix-dependencies in your Ant module.


Built on December 15 2017.  |  Portions Copyright 1997-2017 Oracle. All rights reserved.