NetBeans Architecture Answers for Static Analysis Core module


Interfaces table

Group of java interfaces
Interface NameIn/OutStabilitySpecified in What Document?
CodeAnalysisExportedFriend

SPI for code analysis tools.

CommonAnnotationsAPIImportedStable

The module is needed for compilation. The module is used during runtime. Specification version 1.13 is required.

ClassPathAPIsImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.32 is required.

ProgressImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.40 is required.

ProgressSwingImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.40 is required.

AutoUpdateUIImportedStable

The module is needed for compilation. The module is used during runtime. Specification version 1.35 is required.

MimeLookupAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.25 is required.

OptionsDialogSPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.25 is required.

ParsingAPIImportedStable

The module is needed for compilation. The module is used during runtime. Specification version 9.0 is required.

IndexingAPIImportedStable

The module is needed for compilation. The module is used during runtime. Specification version 9.0 is required.

ProjectAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.42 is required.

ProjectUIAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.78 is required.

BaseProjectUIAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.78 is required.

GeneralQueriesAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.27 is required.

RefactoringAPIImportedUnder Development

The module is needed for compilation. The module is used during runtime. Specification version 1.22 is required.

SettingsAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.34 is required.

EditorHintsSPIImportedStable

The module is needed for compilation. The module is used during runtime. Specification version 1.22 is required.

ActionsAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 6.25 is required.

org.openide.awtImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 7.42 is required.

DialogsAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 7.24 is required.

ExplorerAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 6.42 is required.

FilesystemsAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 9.0 is required.

LoadersAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 7.61 is required.

NodesAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 7.27 is required.

EditorAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 6.44 is required.

UtilitiesAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 9.3 is required.

WeakListener.setAccessibleImportedUnder Development

The module is needed for compilation. The module is used during runtime. Specification version 9.3 is required.

LookupAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 8.12 is required.

WindowSystemAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 6.49 is required.


General Information


Project and platform dependencies


Deployment


Compatibility with environment


Access to resources


Lookup of components


Execution Environment


Format of files and protocols


Performance and Scalability