Skip navigation links

NetBeans Architecture Answers for Java Common Project API module

WARNING: answering questions version 1.23 rather than the current 1.29.

Interfaces table

Group of java interfaces
Interface NameIn/OutStabilitySpecified in What Document?
AntLoggerImportedStable

The module is needed for compilation. The module is used during runtime. Specification version 3.73 is required.

CommonAnnotationsAPIImportedStable

The module is needed for compilation. The module is used during runtime. Specification version 1.6 is required.

JPDADebuggerAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 3.14 is required.

JavaSupportAPIsImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.66 is required.

ClassPathAPIsImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.54 is required.

ProgressImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.40 is required.

ProgressSwingImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.40 is required.

DataSystemsAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.9 is required.

org.netbeans.libs.antlr3.runtimeImportedPrivate

The module is needed for compilation. The module is used during runtime. Specification version 1.2 is required.

org.netbeans.libs.javacapiImportedPrivate

The module is needed for compilation. The module is used during runtime. Specification version 8.19 is required.

org.netbeans.api.autoupdateImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.53 is required.

EditorUtilitiesAPIImportedUnder Development

The module is needed for compilation. The module is used during runtime. Specification version 1.64 is required.

ExternalExecutionAPIImportedStable

The module is needed for compilation. The module is used during runtime. Specification version 1.30 is required.

JavaPlatformAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.43 is required.

JavaPlatformUIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.36 is required.

org.netbeans.modules.java.preprocessorbridgeImportedPrivate

The module is needed for compilation. The module is used during runtime. Specification version 1.49 is required.

JavaProjectAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.72 is required.

JavaProjectUIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.62 is required.

JavaSourceAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 2.32 is required.

java.sourceuiImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.1 is required.

AntProjectAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.62 is required.

AntProjectUIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.62 is required.

ProjectLibrariesAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.49 is required.

project_libs_uiImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.48 is required.

ProjectAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.43 is required.

ProjectUIAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.78 is required.

BaseProjectUIAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.78 is required.

GeneralQueriesAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.11 is required.

ActionsAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 6.2 is required.

org.openide.awtImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 6.12 is required.

DialogsAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 7.6 is required.

ExecutionAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 9.0 is required.

FilesystemsAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 9.0 is required.

org.openide.filesystems.nbImportedPrivate

The module is needed for compilation. The module is used during runtime. Specification version 9.0 is required.

InputOutputAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.56 is required.

LoadersAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 7.61 is required.

ModulesAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 7.4 is required.

NodesAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 7.3 is required.

EditorAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 6.67 is required.

WeakListener.setAccessibleImportedUnder Development

The module is needed for compilation. The module is used during runtime. Specification version 9.3 is required.

LookupAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 8.0 is required.

UtilitiesAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 9.3 is required.

WindowSystemAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 6.2 is required.


General Information


Project and platform dependencies


Deployment


Compatibility with environment


Access to resources


Lookup of components


Execution Environment


Format of files and protocols


Performance and Scalability