NetBeans Architecture Answers for Java Hints Test API module


Interfaces table

Group of java interfaces
Interface NameIn/OutStabilitySpecified in What Document?
java.hints.testExportedUnder Development

API to create tests for the custom Java hints.

CommonAnnotationsAPIImportedStable

The module is needed for compilation. The module is used during runtime. Specification version 1.13 is required.

JavaSupportAPIsImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.37 is required.

ClassPathAPIsImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.32 is required.

org.netbeans.core.startupImportedPrivate

The module is needed for compilation. The module is used during runtime. Specification version 1.60 is required.

org.netbeans.libs.javacapiImportedPrivate

The module is needed for compilation. The module is used during runtime. Specification version 7.9 is required.

org.netbeans.libs.junit4ImportedPrivate

The module is needed for compilation. The module is used during runtime. Specification version 1.13 is required.

MimeLookupAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.25 is required.

org.netbeans.modules.java.j2seplatformImportedPrivate

The module is used during runtime. Specification version 1.42 is required.

org.netbeans.modules.java.lexerImportedPrivate

The module is needed for compilation. The module is used during runtime. Specification version 1.17 is required.

org.netbeans.modules.java.sourceImportedPrivate

The module is needed for compilation. The module is used during runtime.

JavaSourceAPIImportedOfficial

The module is needed for compilation. The module is used during runtime.

LexerAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.43 is required.

org.netbeans.modules.nbjunitImportedPrivate

The module is needed for compilation. The module is used during runtime. Specification version 1.74 is required.

ParsingAPIImportedStable

The module is needed for compilation. The module is used during runtime.

IndexingAPIImportedStable

The module is needed for compilation. The module is used during runtime.

org.netbeans.modules.parsing.nbImportedPrivate

The module is used during runtime. Specification version 1.4 is required.

ProjectAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.41 is required.

org.netbeans.modules.projectapi.nbImportedPrivate

The module is used during runtime. Specification version 1.4 is required.

ProjectUIAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.78 is required.

BaseProjectUIAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.78 is required.

RefactoringAPIImportedUnder Development

The module is needed for compilation. The module is used during runtime. Specification version 1.34 is required.

EditorHintsSPIImportedStable

The module is needed for compilation. The module is used during runtime. Specification version 1.22 is required.

spi.java.hintsImportedUnder Development

The module is needed for compilation. The module is used during runtime.

FilesystemsAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 9.0 is required.

LoadersAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 7.61 is required.

NodesAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 7.26 is required.

EditorAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 6.44 is required.

WeakListener.setAccessibleImportedUnder Development

The module is needed for compilation. The module is used during runtime. Specification version 9.3 is required.

LookupAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 8.12 is required.

UtilitiesAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 9.8 is required.


General Information


Project and platform dependencies


Deployment


Compatibility with environment


Access to resources


Lookup of components


Execution Environment


Format of files and protocols


Performance and Scalability