NetBeans Architecture Answers for Java Platform UI module

WARNING: answering questions version 1.24 rather than the current 1.29.

Interfaces table

Group of java interfaces
Interface NameIn/OutStabilitySpecified in What Document?
JavaPlatformUIExportedOfficial

The Java Platform API permits access to installed Java platforms (for example, the J2SE JDK, or various mobile-device emulators for J2ME). Particular platform types are registered by modules and can store customized information about the platform to disk.
Note that this module concentrates the UI part of API. Its desktop-independent counterpart is in the
org.netbeans.modules.java.platform module.

FilesystemsImportedOfficial

Various purposes.

ActionsImportedOfficial

Registration of platform manager action.

DatasystemsImportedOfficial

FolderInstance is used only internally.

JavaSupportAPIsImportedOfficial

To return bootstrap libraries and standard libraries as a ClassPath.

The module is needed for compilation. The module is used during runtime. Specification version 1.18 is required.

WizardsImportedOfficial

Dialogs used to customize platforms.

ModulesImportedOfficial

SpecificationVersion used in the API.

NodesImportedOfficial

For miscellaneous GUI.

CommonAnnotationsAPIImportedStable

The module is needed for compilation. The module is used during runtime. Specification version 1.14 is required.

ClassPathAPIsImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.0 is required.

JavaPlatformAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.36 is required.

org.openide.awtImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 6.2 is required.

DialogsAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 7.8 is required.

ExplorerAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 6.8 is required.

FilesystemsAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 9.0 is required.

LoadersAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 7.61 is required.

ModulesAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 6.2 is required.

NodesAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 6.2 is required.

UtilitiesAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 9.3 is required.

WeakListener.setAccessibleImportedUnder Development

The module is needed for compilation. The module is used during runtime. Specification version 9.3 is required.

LookupAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 8.0 is required.


General Information


Project and platform dependencies


Deployment


Compatibility with environment


Access to resources


Lookup of components


Execution Environment


Format of files and protocols


Performance and Scalability