Skip navigation links

NetBeans Architecture Answers for Java Hints SPI module


Interfaces table

Group of java interfaces
Interface NameIn/OutStabilitySpecified in What Document?
spi.java.hintsExportedUnder Development

SPI to create custom Java hints, including code smell warnings, productivity tips, etc. Please see the Use Cases section for a guide on how to use this SPI.

CommonAnnotationsAPIImportedStable

The module is needed for compilation. The module is used during runtime. Specification version 1.4 is required.

JavaSupportAPIsImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.18 is required.

ClassPathAPIsImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.24 is required.

ProgressImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.40 is required.

ProgressSwingImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.40 is required.

org.netbeans.lib.nbjavacImportedPrivate

The module is needed for compilation. The module is used during runtime.

org.netbeans.libs.javacapiImportedPrivate

The module is needed for compilation. The module is used during runtime. Specification version 8.0 is required.

org.netbeans.libs.javacimplImportedPrivate

The module is needed for compilation. The module is used during runtime.

org.netbeans.libs.luceneImportedPrivate

The module is needed for compilation. The module is used during runtime. Specification version 3.0 is required.

CodeAnalysisImportedFriend

The module is needed for compilation. The module is used during runtime. Specification version 1.8 is required.

EditorModuleAPIImportedUnder Development

The module is needed for compilation. The module is used during runtime. Specification version 1.53 is required.

org.netbeans.modules.editor.documentImportedPrivate

The module is needed for compilation. The module is used during runtime. Specification version 1.3 is required.

TextAPIImportedStable

The module is needed for compilation. The module is used during runtime. Specification version 2.3 is required.

EditorHyperlinkSPIImportedUnder Development

The module is needed for compilation. The module is used during runtime. Specification version 4.0 is required.

editor-code-generatorImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 2.0 is required.

MimeLookupAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.15 is required.

EditorSettingsAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.28 is required.

EditorUtilitiesAPIImportedUnder Development

The module is needed for compilation. The module is used during runtime. Specification version 1.33 is required.

org.netbeans.modules.java.lexerImportedPrivate

The module is needed for compilation. The module is used during runtime. Specification version 1.0 is required.

JavaPlatformAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.16 is required.

JavaProjectAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.62 is required.

org.netbeans.modules.java.sourceImportedPrivate

The module is needed for compilation. The module is used during runtime.

JavaSourceAPIImportedOfficial

The module is needed for compilation. The module is used during runtime.

LexerAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.25 is required.

OptionsDialogSPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.5 is required.

org.netbeans.modules.options.editorImportedPrivate

The module is needed for compilation. The module is used during runtime. Specification version 1.28 is required.

ParsingAPIImportedStable

The module is needed for compilation. The module is used during runtime.

ProjectAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.42 is required.

GeneralQueriesAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 1.18 is required.

RefactoringAPIImportedUnder Development

The module is needed for compilation. The module is used during runtime. Specification version 1.23 is required.

EditorHintsSPIImportedStable

The module is needed for compilation. The module is used during runtime. Specification version 1.22 is required.

ActionsAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 6.15 is required.

org.openide.awtImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 6.10 is required.

DialogsAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 7.0 is required.

ExplorerAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 6.22 is required.

FilesystemsAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 9.0 is required.

LoadersAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 7.61 is required.

ModulesAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 7.3 is required.

NodesAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 6.2 is required.

EditorAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 6.16 is required.

WeakListener.setAccessibleImportedUnder Development

The module is needed for compilation. The module is used during runtime. Specification version 9.3 is required.

LookupAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 8.0 is required.

UtilitiesAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 9.3 is required.

WindowSystemAPIImportedOfficial

The module is needed for compilation. The module is used during runtime. Specification version 6.16 is required.


General Information


Project and platform dependencies


Deployment


Compatibility with environment


Access to resources


Lookup of components


Execution Environment


Format of files and protocols


Performance and Scalability